This project has moved. For the latest updates, please go here.

I can't forward to /graffiti-admin/

Jan 11, 2011 at 10:51 PM
Edited Jan 11, 2011 at 10:52 PM

http://graffiticms.codeplex.com/wikipage?title=Installing%20Graffiti&referringTitle=Getting%20Started --> i refer here

 

I user sql Server 2005 and Visual 2008. When i run, by default forwarded to /graffiti-setup/ (step 7 with tutorial), but can't forward to /graffiti-admin/ automatically (step 8), i also at /graffiti-setup/ page.

I enter http://localhost:2786/graffiti-admin/ manually into Address bar (now is step 8), i enter enter user name and password, it forward to http://localhost:2786/graffiti-setup/ automatically (turn to step 7).

I make sure user name and password True.

Thanks a lot of.

Coordinator
Jan 11, 2011 at 11:15 PM

Are you using the source code or the binary download? If the source code, make sure you are using the 1.3 branch and NOT the trunk code. The trunk code has a bug causing the behavior you mention.

Jan 12, 2011 at 2:27 AM

hello jeremyhodges.

Yes, i used source code, and used trunk code. I try use source code in Branches\v1.3\src but project Graffiti.Web is unavalible, i can't reload it.

This here my actions :

i downloads source code here : http://graffiticms.codeplex.com/sourcecontrol/list/changesets?ProjectName=graffiticms, and selected download last version.

Libarary download here : http://graffiticms.com/lib/lib.zip.

I extract lib.zip get two file *.dll and move folder \Branches\v1.3\src\Lib.

Run file  \Branches\v1.3\srcGraffiti.sln, but project Graffiti.Web is unavalible.

I make sure Database work well

Thanks jeremyhodges.

Jan 13, 2011 at 1:59 AM

OK, i can run it. Thanks

Jun 17, 2011 at 1:22 PM
Edited Jun 17, 2011 at 1:46 PM

I have the same problem and i dont really get whats trunk and what are these branches.

 

I downloaded the latest version (Graffiti CMS 1.3 Beta 2), followed this tutorial http://graffiticms.codeplex.com/wikipage?title=Installing%20Graffiti&referringTitle=Getting%20Started. I stucked on step 8. when i enter username and password it's just refresh the page.

What can i do?

 

Greetings!

 

 

EDIT: I found 1.3 Branchee, put it on server, error appear:

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately. 

Compiler Error Message: CS0246: The type or namespace name 'Telligent' could not be found (are you missing a using directive or an assembly reference?)

Source Error:

 
Line 98: 			<namespaces>
Line 99: 				<add namespace="Graffiti.Core"/>
Line 100:				<add namespace="Telligent.Glow"/>
Line 101:			</namespaces>
Line 102:			<controls>

 

Coordinator
Jun 18, 2011 at 5:06 PM

I really think the graffiti-setup loop issue is related to permissions, maybe having to do with the sql database. I've still never had this problem and in fact just tested it with the latest code. You should have run at least three sql scripts on your sql database before it can work at all.

For SQL 2005 or 2008, Graffiti_SQL_Scheme.sql, Graffiti_SQL_Data.sql and SQL_IntegratedSecurity.sql. The guide you referred to doesnt include those and in fact I think we may have overlooked those steps in our documentation all together. Just look at the read_me.txt included with either the source code or the beta release for info on what scripts to use, but the 3 I mentioned should be the ones you need. (I'll try to update the documentation with the db setup steps from the read me shortly.)

As for the Graffiti.Web is unavalible issue, its just the nature of sharing IIS project files. Sometimes an absolute path gets stuck in one of the project or solution files and you just have to tweak it. I dont think the newest code is going to fix the graffiti-setup problems you're having.

Madchen - The Telligent.Glow error probably means you didnt place the two Telligent dlls in the bin folder. They dont come pre-installed with the source. You have to download them separately. They do come included with the beta release.

Coordinator
Jun 18, 2011 at 5:36 PM

http://graffiticms.codeplex.com/wikipage?title=Configuring%20A%20New%20Database

Aug 14, 2011 at 9:03 PM

These instructions are not helping me and I followed everything in great detail.

I'm attempting to use MySQL.

1. I am not sure if the scripts are running correctly. When I run the data script it does not seem to create a user and if that is not happening, how do I configure the Web.config file correctly. So, my basic problem is that I cannot get past step 6.

2. All I get are run time errors

Any help would be greatly appreciated sooner than later please.

Coordinator
Aug 15, 2011 at 2:49 AM
sdse78 wrote:

These instructions are not helping me and I followed everything in great detail.

I'm attempting to use MySQL.

1. I am not sure if the scripts are running correctly. When I run the data script it does not seem to create a user and if that is not happening, how do I configure the Web.config file correctly. So, my basic problem is that I cannot get past step 6.

2. All I get are run time errors

Any help would be greatly appreciated sooner than later please.

I'm not sure what user you are expecting the script to create. For the web.config, you must provide the username and password for your MySql account - the account created on the MySql service itself, not a username and password stored in the database.