This project has moved. For the latest updates, please go here.

Get 500 Internal Server Error on /feed

Oct 24, 2012 at 6:44 PM

I get this when I hit the /feed page. I am currently getting the error from Feedburner and when I hit it directly.

Any clue as to why?

Coordinator
Oct 25, 2012 at 1:39 PM

The /feed page for what site? And do you have any details with that error? What you've provided so far doesn't give any details. The error page should show additional information or the logs inside the admin section of the site should provide additional details.

Oct 25, 2012 at 2:05 PM

Site: rivercityfargo.org

The logs in the admin site are these 4.

Title MessageUploadFileManager An error occured while deleting an expired upload context.  Reason: Could not find a part of the path 'C:\HostingSpaces\wpsnvfiq\rivercityfargo.org\wwwroot\files\uploads'.

Error in Google Sitemap plug-in System.NullReferenceException: Object reference not set to an instance of an object.     at Graffiti.Core.Macros.FullUrl(String absoluteUrl)     at GraffitiExtras.Plugins.Sitemap.Sitemap.AddSiteMapToRobots()

Feed The feed http://twitter.com/statuses/user_timeline/rivercityfargo.rss (Name:Feed: Twitter / rivercityfargo Id:7e0df832-870b-40cf-ac04-096f8b8a1ffd was not successfully updated. Reason: The remote server returned an error: (404) Not Found.

Feed The feed http://graffiticms.com/blog/feed/ (Name:Feed: Graffiti CMS: Blog Id:e9d6d831-a61f-4a22-9d8a-0f8352c3a793 was not successfully updated. Reason: The remote server returned an error: (404) Not Found.

Coordinator
Oct 27, 2012 at 1:14 AM

error #3 - this is caused by a recent deprecation of the old twitter API. The twitter widget is therefore outdated and broken so I'll update the graffiti source code today. The current API uses the rss feed in this format: https://api.twitter.com/1/statuses/user_timeline.rss?screen_name=rivercityfargo

error #4 - this seems to indicate you are using a very old version of graffiti because graffiticms.com doesnt exist anymore. You should update to the current code, which means you'd need to compile the most current source code if you want the twitter fix as well.

The other two errors seem like server side issues or maybe an outdated graffiti extras plugin?? You could grab the current version here http://graffitiextras.codeplex.com/. Updating to the current GraffitiCMS version may help as well. I'd recommend doing that first and if you still have problems, report back.