This project has moved. For the latest updates, please go here.
1

Resolved

Write a new post is broken (IE 10)

description

Looks like I cannot edit a new post with IE 10: the edit box is gray and I cannot type anything.

comments

JackActually wrote Mar 15, 2013 at 4:37 PM

Ran into a similar problem with the FileBrowser in IE9. We put a workaround in place to force IE to emulate IE8 while rendering the admin pages. I've tested the workaround with this issue and confirms that it does resolve the locked edit box issue.

All you need to do is add the following line immediately after the opening head tag in AdminMasterPage.master (located in graffiti-admin\common):
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8"/>
That should do the trick.

TorstenR wrote Mar 15, 2013 at 5:57 PM

Thanks JackActually - you are right.

But it would be better if the a "real" fix without downgrading the rendering would be applied to get it work with current IE versions...

jkillebrew wrote Mar 16, 2013 at 4:37 PM

Are you using the latest beta release or have you tried compiling the latest source code?

As of Mar 24, 2011 the source contains a newer version of the editor which works just fine in IE9 and 10 on my sites. If your editor is older than version 3.5.2, I think you could download the source and just swap out the entire folder at <siteroot>_utility\ckeditor with the newer version. At that point you should have ckeditor 3.6.3 which even supports iOS 5.

We should probably release the current code soon.

jkillebrew wrote May 11, 2013 at 6:20 AM

The issue with the file browser in IE9 and IE10 has been resolved in the source and will be included in the next release.

wrote May 11, 2013 at 6:20 AM

wrote May 16, 2013 at 9:38 AM

wrote May 16, 2013 at 9:38 AM

wrote Jun 14, 2013 at 7:16 AM